GWT/Eclipse Fehlermeldung: Please configure an App Engine SDK.

Um sich mit GWT vertraut zu machen wird eine Installation von Eclipse IDE for Java Developers benötigt, sowie des das GWT Plugins für die Eclipse IDE. Bei der GWT Plugin Installation kann jeder selbst auswählen was er installiert. In diesem Fall wurde(sollte) auf alles bzgl. Androide verzichtet. Augenscheinlich war die Installation erfolgreich, den Eclipse lief und der Button zum anlegen eines neuen GWT Web Application Project war vorhanden.
GWT Web Application Project

Bei der Durchführung der Erstellung einer GWT Beispiel APP tauchte der folgende Fehler auf.

Please configure an App Engine SDK.

Please configure an App Engine SDK.

Auf Grund des Hinweis SDK unter der vorherigen Google Dokumentation bzgl. mindestens Java 1.6 Version, kommt der Gedanke das die benötigte JDK von Eclipse bzw. GWT nicht gefunden wird. Dies ist aber nicht der Fall. Hierbei handelt es sich um das Software Development Kit(SDK) der GWT App Engine. (Trotzdem: Java Version Mac prüfen?)

Fazit: Letztlich wurde das GWT Plugin nicht ordentlich installiert, weil SDKs/Google App Engiene Java SDK fehlt.
Lösung: Einfach den fehlenden Teil des GWT Plugin’s installieren.

Lösung
In Eclipse Menü Help / Install New Software… aufrufen.
eclipse_install_new_software

Für Eclipse (Luna) in die Work with Box wieder folgende URL eingeben: https://dl.google.com/eclipse/plugin/4.4 und anschließend unter SDKs den Punkt Google App Engiene Java SDK aktivieren.
eclipse_gwt_plugin_fehlendes_auswaehlen

Abschließend einfach „Next“, „Next“, „Accept License“ und „Finish“. Den Warnhinweis noch mit „OK“ bestätigen. Fertig!

Alternative (einfache) Lösung
Sollte der Irrweg Richtung Java nicht eingeschlagen worden sein, so soll auch einfach das klicken auf „Configure SDK“ bei dem Punkt „Use Google Web Toolkit“ Abhilfe schaffen. (Leider nicht ausprobiert)
eclipse_new_gtw_app


Java Version Mac prüfen

Verwirrend beim Mac OS X könnte sein, wenn versucht wird die aktuelle JDK Version wie nachfolgend zu bestimmen. Unklar ist ob Eclipse Current oder CurrentJDK nutzt.

Aus dem Grunde sollte alternativ die Konfiguration von Eclipse geprüft werden.
eclipse_jdk_version_configuration
Glossar:
java – Führt compelierten Java Code aus
javac – Ist der compeliert Java Code
SDK = Software Development Kit
JDK = Java Development Kit (das SDK für Java), es enthält JRE, den Compiler und Werkzeuge wie (JavaDoc, oder Java Debugger)
JRE = Java Runtime Environment ist im Grunde die Java Virtual Machine worin jedes Java Programm läuft.

(Visited 54 times, 1 visits today)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.